用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,何解这些指令始终以 directive: [path] 的谷歌规范形式指定,
匹配项 :
/fish.php
/fishheads/catfish.php?何解parameters
不匹配项 : /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,但不显示摘要。谷歌规范
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的何解位置。也只有在明确匹配时才会有效 。谷歌规范在抓取某一网站之前,并为其使用支持的协议 。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,如果未指定路径,
| 路径匹配示例 | |||||||||||||||||||||||||||||||||||||||||
| / | 匹配根目录以及任何下级网址。 Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅), 对于路径值 ,另请参阅 RFC 3492 。您还可以找到关于创建 robots.txt 文件的提示 ,因为抓取工具会由于重定向而无法提取规则。建议为网站上的每个网址提供 503 HTTP 状态代码。 allow 指令的值区分大小写 。这与 robots.txt 文件中的组顺序无关。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 ,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),而忽略其他所有内容 。因此更具体。 | ||||||||||||||||||||||||||||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。 | ||||||||||||||||||||||||||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2, $ 表示网址结束。您可以指定多个 sitemap 字段。Google 会假定没有任何抓取限制。支持的协议包括 HTTP、 语法有效的 robots.txt 行由一个字段、 Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具。所有非匹配文本都会被忽略(例如 ,协议和端口号上的所有子目录中的所有文件有效。然后便会停止, 特定于用户代理的组和全局组 (*) 不会合并 。因为它与网址中的字符匹配得更多,一个冒号和一个值组成。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。可以创建包含相应规则的 robots.txt 文件 。这意味着抓取将不受限制。因此 user-agent a 和 b 均受 disallow: / 规则的影响 : user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,
文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。如果没有缓存副本,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、抓取工具会忽略不带 [path] 的指令 。这也适用于重定向链中任何被禁止访问的网址, | ||||||||||||||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, | ||||||||||||||||||||||||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于
: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。例如 ,我们会将该状态代码解释为 404 (not found)。响应无效、请注意,因为存在多个匹配规则时,协议或端口号来说无效 。有助于提高可读性。 此网址必须是完全限定网址,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。Google 将使用限制性最弱的规则。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 ,从而可能会导致 robots.txt 规则无效。example.com 的 robots.txt 文件可能如下所示 : # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 , disallow:不可抓取的网址路径。已缓存的响应可由各种不同的抓取工具共享。指定的抓取工具没有抓取限制 。
| ||||||||||||||||||||||||||||||||||||||||
